HeroWarez.org » Mobiles » Snoticles v1.1

Snoticles v1.1
Snoticles v1.1 | 80.9 MB
Requirements: Compatible with iPhone 3GS, iPhone 4, iPhone 4S, iPod touch (3rd generation), iPod touch (4th generation) and iPad. Requires iOS 4.0 or later.

"Snoticles v1.1"

HI-SPEED DOWNLOAD
Free 300 GB with Full DSL-Broadband Speed!




Snoticles v1.1
Snoticles v1.1 | 80.9 MB
Requirements: Compatible with iPhone 3GS, iPhone 4, iPhone 4S, iPod touch (3rd generation), iPod touch (4th generation) and iPad. Requires iOS 4.0 or later.

Description:
Game Center

Open iTunes to buy and download apps.
View More By This Developer
Description

Help the Snoticles defend their world from the rampaging Blots! Each of the four Snoticles -- Zit, Dread, Spark and Snot -- has a unique power to help you get the job done. Zit chucks rocks. Dread hurls backpack bombs. Spark shoots fireballs. And Snot? He lobs balls of phlegm. Master each Snoticle's individual ability and discover interesting ways to use them together. Conquer the game's unique puzzle mechanics as you explore dozens of levels across five separate worlds. Do a good job, and the Snoticles will surely thank you for their newfound Blot-free existence.

From Adult Swim Games, producers of "Robot Unicorn Attack" and "Major Mayhem".

Requirements for Snoticles:
iPhone 3GS, iPhone 4, iPhone 4S
iPod touch 3rd/4th generation
iPad, iPad 2

HAVING PROBLEMS? Help us fix any issues you run into while playing ????? email [email protected] and tell us what you're seeing along with the device/OS version you're on.

P A S S W O R D    P R O T E C T E D ! 
PASSWORD WILL BE PUBLISHED HERE TOMORROW!
 PLEASE ADD PAGE TO YOUR FAVORITS

Free 300 GB with 10 GB High-Speed(No Password BACKUP)


Hide Your IP & Protect Your Privacy!
Get Your 15 Day Free Trial Now.

Bookmark this page

Tags: iPhone, Snoticles, touch, generation, Requirements, Dread, their, Spark, unique, iPhoneAll, youre, Snoticlesv, later, Compatible, Description, Requires, existence, Major, Mayhem, HAVING