HeroWarez.org » Tag cloud » RequirementsCompatible

Rayman 2 The Great Escape 1.0.2 iPhone iPad and iPod touch

Rayman 2 The Great Escape 1.0.2 iPhone iPad and iPod touch

Application Details

Category : Games
Current Version : 1.0.2
Language : English, French, German, Italian, Japanese, Spanish
Requirements : Compatible with iPhone, iPod touch, and iPad.Requires iOS 3.1.2 or later
Rating : Rated 9+

The Settlers 1.1.9 iPhone iPad and iPod touch

The Settlers 1.1.9 iPhone iPad and iPod touch

Application Details

Category : Games
Current Version : 1.1.9
Language : English, French, German, Italian, Japanese, Spanish
Requirements : Compatible with iPhone, iPod touch, and iPad.Requires iOS 3.1.2 or later
Rating : Rated 9+

SPY mouse 1.0.5 iPhone iPad and iPod touch

SPY mouse 1.0.5 iPhone iPad and iPod touch

Application Details

Category : Games
Current Version : 1.0.5
Language : English, Chinese, Dutch, French, German, Italian, Japanese, Korean, Spanish
Requirements : Compatible with iPhone, iPod touch, and iPad.Requires iOS 3.0 or later
Rating : Rated 4+

The Sims 3 1.3.86 iPhone iPad and iPod touch

The Sims 3 1.3.86 iPhone iPad and iPod touch

Application Details

Category : Games
Current Version : 1.3.86
Language : English, Chinese, French, German, Italian, Japanese, Korean, Spanish
Requirements : Compatible with iPhone, iPod touch, and iPad.Requires iOS 3.0 or later
Rating : Rated 12+

Tom Clancys H.A.W.X 1.1.3 iPhone iPad and iPod touch

Tom Clancys H.A.W.X 1.1.3 iPhone iPad and iPod touch

Application Details

Category : Games
Current Version : 1.1.3
Language : English, French, German, Italian, Japanese, Spanish
Requirements : Compatible with iPhone, iPod touch, and iPad.Requires iOS 2.2.1 or later
Rating : Rated 9+

Trenches II 1.0.0 iPhone iPad and iPod touch

Trenches II 1.0.0 iPhone iPad and iPod touch

Application Details

Category : Games
Current Version : 1.0.0
Language : English, French, German, Italian, Spanish
Requirements : Compatible with iPhone 3GS, iPhone 4, iPhone 4S, iPod touch (3rd generation), iPod touch (4th generation) and iPad.Requires iOS 3.1 or later
Rating : Rated 12+

Incredible Snowboard 1.02 iPhone iPad and iPod touch

Incredible Snowboard 1.02 iPhone iPad and iPod touch

Application Details

Category : Games
Current Version : 1.02
Language : English, Korean
Requirements : Compatible with iPhone, iPod touch, and iPad.Requires iOS 3.1 or later
Rating : Rated 4+

Pages 1.6 iPhone iPad and iPod touch

Pages 1.6 iPhone iPad and iPod touch

Application Details

Category : Productivity
Current Version : 1.6
Language : English, Catalan, Chinese, Croatian, Czech, Danish, Dutch, Finnish, French, German, Greek, Hungarian, Indonesian, Italian, Japanese, Korean, Malay, Norwegian, Polish, Portuguese, Romanian, Russian, Slovak, Spanish, Swedish, Thai, Turkish, Ukrainian, Vietnamese
Requirements : Compatible with iPhone 3GS, iPhone 4, iPhone 4S, iPod touch (3rd generation), iPod touch (4th generation) and iPad.Requires iOS 5.1 or later.
Rating : Rated 4+

Burning Run 1.0.0 iPhone iPad and iPod touch

Burning Run 1.0.0 iPhone iPad and iPod touch

Application Details

Category : Games
Current Version : 1.0.0
Language : English
Requirements : Compatible with iPhone, iPod touch, and iPad.Requires iOS 3.1 or later
Rating : Rated 4+

blade of darkness 1.3 iPhone iPad and iPod touch

blade of darkness 1.3 iPhone iPad and iPod touch

Application Details

Category : Games
Current Version : 1.3
Language : English
Requirements : Compatible with iPhone, iPod touch, and iPad.Requires iOS 3.2 or later
Rating : Rated 9+ for the following: